Router-language

From Alessandro's Wiki
Jump to: navigation, search

Foundry

DLink

xStack ® DGS-3200 Series Layer 2 Gigabit Managed Switch CLI Manual 184 23 VLAN Command List create vlan <vlan_name 32 > tag <vlanid 2-4094> { type [1q_vlan advertisement | private_vlan] } create vlan vlanid <vidlist> { type [1q_vlan | private_vlan] { advertisement } } delete vlan <vlan_name> delete vlan vlanid <vlanid_list> config vlan < vlan_name > { [ add [ tagged | untagged | forbidden ] | delete ] <portlist> | advertisement [ enable | disable ] } config vlan vlanid <vidlist> { [ add [ tagged | untagged | forbidden ] | delete ] <portlist> | advertisement [ enable | disable ]| name <vlan_name>} config vlan <vlan_name > delete <portlist> config vlan vlanid <vlanid_ list> delete <portlist> config gvrp [<portlist> | all] {state [enable | disable] | ingress_checking [enable | disable] |acceptable_frame[tagged_only | admit_all] pvid<vlanid 1-4094> } enable gvrp disable gvrp show vlan { <vlan_name 32> | vlanid <vlanid_list> | ports <portlist>} show gvrp {<portlist>} enable pvid auto_assign disable pvid auto_assign show pvid auto_assign config private_vlan [<vlan_name 32> | vid <vlanid 1-4094>] [add [isolated | community] | remove] [<vlan_name 32> | vlanid <vidlist>] show private_vlan { [vlan_name 32> | vlanid <vidlist>] }

show

 802-1w                 Rapid Spanning tree IEEE 802.1w D10 status
 aaa                    Show TACACS+ and RADIUS server statistics
 access-list            Show access list hit statistics
 acl-on-arp             Show ARP ACL filtering
 arp                    Arp table
 auth-mac-addresses     MAC Authentication status
 batch                  Batch commands
 cable-diagnostics      Show Cable Diagnostics
 chassis                Power supply/fan/temperature
 clock                  System time and date
 configuration          Configuration data in startup config file
 debug                  Debug information
 default                System default settings
 dot1x                  dot1x  information
 errdisable             Errdisable status
 fdp                    CDP/FDP information
 flash                  Flash memory contents
 interfaces             Port status
 ip                     IP address setting
 ipv6                   IP setting
 link-aggregate         802.3ad Link Aggregation Information
 link-error-disable     Link Debouncing Control
 link-keepalive         Link Layer Keepalive
 logging                System log                               
 mac-address            MAC address table
 media                  Gig port SX/LX/LHA/LHB
 memory                 System memory usage
 metro-ring             metro ring protocol information
 mirror                 Mirror ports
 monitor                Monitor ports
 mstp                   show MSTP (IEEE 802.1s) information
 port                   Show port security
 priority-mapping       802.1Q tagged priority setting
 processes              Active process statistics
 protected-link-group   Show Protected Link Group Details
 ptrace                 Global ptrace information
 qos-profiles           QOS configuration
 qos-tos                IPv4 ToS based QoS
 radius                 show radius server debug info
 rate-limit             Rate-limiting table and actions
 redundancy             Display management redundancy details
 relative-utilization   Relative utilization list
 reload                 Scheduled system reset
 rmon                   Rmon status
 running-config         Current running-config
 sflow                  sflow information
 snmp                   SNMP statistics                          
 sntp                   Show SNTP
 span                   Spanning tree status
 statistics             Packet statistics
 stp-bpdu-guard         Show stp bpdu guard status
 stp-group              Spanning Tree Group Membership
 stp-protect-ports      Show stp-protect enabled ports and their BPDU drop
                        counters
 tech-support           System snap shot for tech support
 telnet                 Telnet connection
 topology-group         Topology Group Membership
 traffic-policy         Show traffic policy definition
 transmit-counter       Transmit Queue Counters
 trunk                  Show trunk status
 users                  User accounts
 version                System status
 vlan                   VLAN status
 vlan-group             VLAN Group Membership
 voice-vlan             Show voice vlan
 vsrp                   Show VSRP commands
 web-connection         Current web connections
 who                    User login
 |                      Output modifiers
 <cr>      

enable

  • when logged in, the "enable" command give you the administration rights
  • in this status we can monitor e check configuration.
$ enable
password...
# _
  • entering in "edit configuration" mode, you can edit the configuration, live! be very careful
config [te]
password...
(config)#
  • after making changes, you can check them with this command (because "show config" will give you the configuration saved in memory, not the running one that you just modified.
(config)# show running-config
[...]
  • after all your checks, this is the command to save the changes permanently.
(config)# write memory
#
  • an option to backup the configuration is to copy it by TFTP to a server.
#copy running-config tftp 1.2.3.123 router-config-20122112.txt
 #Upload running-config to TFTP server done.

show cpu

show cpu

31 percent busy, from 3248 sec ago 1	sec avg: 
31 percent busy 5	sec avg: 
31 percent busy 60 sec avg: 
31 percent busy
 
300 sec avg: 31 percent busy
  • cpu/process utilizaiton
# show process cpu
Process Name
ACL
ARP BGP DOT1X GVRP ICMP IP L2VLAN OSPF RIP STP VRRP
5Sec(%)	1Min(%)
0.00	0.00
0.01	0.01 0.00	0.00 0.00	0.00 0.00	0.00 0.00	0.00 0.00	0.00 0.01	0.00 0.00	0.00 0.00	0.00 0.00	0.00 0.00	0.00
5Min(%)	15Min(%)
Runtime(ms)
0.00	0.00	0
0.01	0.01	714 0.00	0.00	0 0.00	0.00	0 0.00	0.00	0 0.00	0.00	161 0.00	0.00	229 0.00	0.01	673 0.00	0.00	0 0.00	0.00	9 0.00	0.00	7 0.00	0.00	0

port status short

  • show interface brief
Port  Link    State     Dupl Speed Trunk Tag Priori MAC            Name        
1     Up      Forward   Full 1G    None  No  level0 0012.f286....              
2     Disable None      None None  None  No  level0 0012.f286....                
 
Port  Link    State     Dupl Speed Trunk Tag Priori MAC            Name        
ve10  Up      N/A       N/A  N/A   None  N/A N/A    0012.f286....

ip traffic

#show ip traffic 
IP Statistics
  249333533 received, 92410 sent, 248630753 forwarded
  0 filtered, 0 fragmented, 0 reassembled, 4480 bad header
  495 no route, 0 unknown proto, 0 no buffer, 43582 other errors
 
ARP Statistics
  151530 total recv, 149155 req recv, 214351 req sent, 67830 rep sent
  0 pending drop, 0 invalid source, 0 invalid dest
 
ICMP Statistics
Received:
  13364 total, 25 errors, 103 unreachable, 25 time exceed
  0 parameter, 0 source quench, 0 redirect, 13202 echo, 
  9 echo reply, 0 timestamp, 0 timestamp reply, 0 addr mask
  0 addr mask reply, 0 irdp advertisement, 0 irdp solicitation
Sent:
  55536 total, 0 errors, 38105 unreachable, 4205 time exceed
  24 parameter, 0 source quench, 0 redirect, 0 echo, 
  13202 echo reply, 0 timestamp, 0 timestamp reply, 0 addr mask
  0 addr mask reply, 0 irdp advertisement, 0 irdp solicitation
 
UDP Statistics
  173951 received, 15129 sent, 119850 no port, 0 input errors

MAC address table

show mac-address
Total active entries from all ports = 69
MAC-Address     Port         Type       Index      VLAN 
0800.270c.ce47  5            Dynamic    30         113  
0011.7800.9a44  8            Dynamic    14232      200

ethernet data flow statistics

  • show rmon statistics
Ethernet statistics 1 is active, owned by monitor
 Interface 1 (ifIndex 1) counters
           Octets          62219423556
      Drop events                    0             Packets             74215428
   Broadcast pkts                  613      Multicast pkts                83808
 CRC align errors                    0      Undersize pkts                    0
    Oversize pkts                    0           Fragments                    0
          Jabbers                    0          Collisions                    0
 
 Packet size counters
               64              8199939           65 to 127             21283872
       128 to 255              2667477          256 to 511              1406813
      512 to 1023              2001555        1024 to 1518             38655772

physical media installed in port

  • show media
1:M-SX 2:   3:   4:   5: C 6: C 7: C 8: C 9: C 10: C 11: C 12: C 13: C 14: C 15: C 16: C 17: C 18: C 19: C 20: C 21: C 22: C 23: C 24: C
  • C1550 – CWDM transceiver with 1550 nm wavelength
  • EFM-U – 1000Base-BX10-U fiber (uplink) transceiver
  • EFM-D – 1000Base-BX10-D fiber (downlink) transceiver
  • M-FX – 100BaseFX fiber mini-GBIC
  • M-FXB1 or M-FXB2 – 100BaseFX fiber mini-GBIC
  • M-LX – 1000BaseLX fiber mini-GBIC
  • M-SX – 1000BaseSX fiber mini-GBIC
  • M-TX – 1000BaseTX copper mini-GBIC
  • M-XR – 1000BaseSX 2 fiber mini-GBIC
  • FXB1 or FXB2 – 1000BaseBX fiber mini-GBIC
  • M-LHA 1000BaseLHA fiber mini-GBIC

interface speed

Router(config)# interface e 8 
Router(config-if-e1000-8)# speed-duplex 10-full


ethernet details

  • show interface ethernet 1
GigabitEthernet1 is up, line protocol is up 
  Hardware is GigabitEthernet, address is 0012.f286.7e40 (bia 0012.f286.7e40)
  Configured speed auto, actual 1Gbit, configured duplex fdx, actual fdx
  Configured mdi mode AUTO, actual MDI
  Member of L2 VLAN ID 10, port is untagged, port state is FORWARDING
  BPDU guard is Disabled, ROOT protect is Disabled
  Link Error Dampening is Disabled
  STP configured to ON, priority is level0
  Flow Control is config enabled, oper enabled, negotiation disabled
  mirror disabled, monitor disabled
  Not member of any active trunks
  Not member of any configured trunks
  No port name
  IPG MII 96 bits-time, IPG GMII 96 bits-time
  IP MTU 1500 bytes, encapsulation ethernet
  300 second input rate: 262016 bits/sec, 119 packets/sec, 0.02% utilization
  300 second output rate: 1558744 bits/sec, 178 packets/sec, 0.15% utilization
  35819040 packets input, 31760156880 bytes, 0 no buffer
  Received 559 broadcasts, 83280 multicasts, 35735201 unicasts
  0 input errors, 0 CRC, 0 frame, 0 ignored
  0 runts, 0 giants
  38293277 packets output, 30371035971 bytes, 0 underruns
  Transmitted 53 broadcasts, 0 multicasts, 38293224 unicasts
  0 output errors, 0 collisions

ip routes

show ip
Global Settings
  ttl: 64, arp-age: 10, bootp-relay-max-hops: 4
  router-id : 0.0.0.0
  enabled : UDP-Broadcast-Forwarding  Source-Route  Load-Sharing  RARP  
  disabled: Route-Only  Directed-Broadcast-Forwarding  IRDP  Proxy-ARP  RIP  DVMRP  VRRP  VRRP-Extended  
Static Routes
  Index   IP Address        Subnet Mask       Next Hop Router   Metric Distance
  1       0.0.0.0           0.0.0.0           145.145.24.140    1      1 0
  2       192.168.251.0     255.255.255.0     192.168.252.1     1      1 0

ip interface networks

show ip interface
Interface       IP-Address      OK?  Method    Status                 Protocol
Ve 10           1.5.4.1  YES  NVRAM     up                     up      
Ve 100          1.2.1.33   YES  NVRAM     up                     up      
Ve 101          1.2.1.129  YES  NVRAM     up                     up      
Ve 102          1.2.1.193  YES  NVRAM     up                     up      
Ve 103          1.2.1.225  YES  NVRAM     up                     up      
Ve 104          1.2.1.241  YES  NVRAM     up                     up      
Ve 105          1.2.1.249  YES  NVRAM     up                     up      
Ve 106          1.2.1.17   YES  NVRAM     up                     up      
Ve 111          1.2.1.65   YES  NVRAM     up                     up      
Ve 112          1.2.1.81   YES  NVRAM     up                     up      
Ve 113          1.2.1.97   YES  NVRAM     up                     up      
Ve 200          1.2.3.4  YES  NVRAM     up                     up

add VLAN

vlan 123 name v-users by port
tagged ethe 2 to 4

VLAN detail

  • show vlans
Total PORT-VLAN entries: 19
Maximum PORT-VLAN entries: 4095
PORT-VLAN 1, Name DEFAULT-VLAN, Priority level0, Spanning tree Off
 Untagged Ports:   2   3   4  19  20 
   Tagged Ports: None
   Uplink Ports: None
 DualMode Ports: None

virtual ethernet configuration

  • is the ip configuration of the vlan subnet
interface ve 300
 port-name v-secondary
 ip access-group 300 in
 ip address 1.2.1.1 255.255.255.240
!
interface ve 100
 port-name v-primary
 ip address 1.2.3.1 255.255.252.0

access list per IP

  • access list used by virtual ethernet
access-list 10 permit 1.2.3.0 0.0.3.255
access-list 10 permit 1.2.1.0 0.0.0.255
access-list 10 deny any log
 
access-list 300 deny ip any 1.2.3.0 0.0.3.255 log
access-list 300 deny ip any 1.2.1.0 0.0.0.255 log
access-list 300 permit ip any any
 
access-list 103 permit ip any 1.2.5.0 0.0.0.255

set DNS

  • add 3 DNS servers:
ip dns server-address 1.2.3.4 10.11.12.13 101.102.103.104
  • del 1 DNS server:
no ip dns server-address 10.11.12.13

SSH management config

 ip ssh  key-authentication no
 ip ssh  source-interface ve 200

add port to VLAN

* add tagged port:
 # vlan 4
 (vlan-4)# tag ethe 11
 # end
* add untagged port
 (vlan-4)# untag ethe 11
 # e
* add untagged port
 (vlan-4)# untag ethe 11
 # end

remove port from VLAN

* remove un-tagged port:
 #vlan 4
 (vlan-4)# no untag ethe 11
 # end
* tagged port
 (vlan-4)# no tag ethe 11
 # e
* tagged port
 (vlan-4)# no tag ethe 11
 # end

change temperature warning level

  • temperature at when the device will give warning
# temperature warning 47
  • temperature at when the device will shut down
# temperature shutdown 57
  • change the polling time interval
# chassis poll-time 200

change logging size

#config te
BR-SSH@coresw1(config)#logging buffered 300
Reload required.  Please write memory and then reload or power cycle.
BR-SSH@coresw1(config)#write memory
Write startup-config done.
BR-SSH@coresw1(config)#end
BR-SSH@coresw1#reload
Are you sure? (enter 'y' or 'n'): y

Cisco